Replacing thermostat...i think it was time

You know the drill..

Moderators: Redneck_Randy, badmoonrising, lakerunner

Message
Author
onlybillhere
Posts: 232
Joined: Tue May 14, 2019 6:41 am

Re: Replacing thermostat...i think it was time

#16 Post by onlybillhere » Thu Apr 08, 2021 9:56 am

UPDATE: guy just called to come pick my boat up.....it's still not fixed and they have no idea what's causing the issue. The good thing is that they are not charging me for any of the work. So back to finding another shop to work on it...this sucks
1995 Sun Tracker 21 Party Barge
60HP Mercury 2 stroke
It's new! to me
Loving the life here in Deland, Fla.

User avatar
curtiscapk
Posts: 5205
Joined: Mon Nov 10, 2008 8:31 am
Location: OP KS\Hillsdale Lake

Re: Replacing thermostat...i think it was time

#17 Post by curtiscapk » Thu Apr 08, 2021 10:34 am

WTF! WEIRD..... Good Luck! :? :?
Craig and Paula
"THE FLOATER" rebuild Spring 2013
viewtopic.php?f=2&t=15328
94 Party Barge 24' 115 merc
Turning Point hustler 14 x 13 prop
22mph gps 3 people
12 F150
Overland Park Ks
Hillsdale Lake, KS

onlybillhere
Posts: 232
Joined: Tue May 14, 2019 6:41 am

Re: Replacing thermostat...i think it was time

#18 Post by onlybillhere » Fri Apr 16, 2021 6:44 am

So last night I finally get to mess with the motor after getting it back from the boat mechanic. It runs ROUGH now....and there is a knocking sound. Mind you the motor was running well before, just the loss of rpm's, but it was running good. Just so happened I had 3 new coils to replace the original ones...well that didn't work. So I have a motor that runs worse than when I dropped it off....I'm not too happy about this
1995 Sun Tracker 21 Party Barge
60HP Mercury 2 stroke
It's new! to me
Loving the life here in Deland, Fla.

User avatar
TWB
Posts: 531
Joined: Sun Mar 18, 2018 7:40 am
Location: Navarre, FL

Re: Replacing thermostat...i think it was time

#19 Post by TWB » Sat Apr 17, 2021 6:33 pm

onlybillhere wrote:
Fri Apr 16, 2021 6:44 am
So last night I finally get to mess with the motor after getting it back from the boat mechanic. It runs ROUGH now....and there is a knocking sound. Mind you the motor was running well before, just the loss of rpm's, but it was running good. Just so happened I had 3 new coils to replace the original ones...well that didn't work. So I have a motor that runs worse than when I dropped it off....I'm not too happy about this
Holy shit, Bill! Did you run it right back to him? That's just ridiculous. Sorry you're having so much trouble, man.

.
Paul & Michele
2003 Landau DX 24' Cruise "Loretta Jane"
2003 Mercury 75hp
My Rebuild: http://pontoonforums.com/viewtopic.php?f=16&t=26135

"Don't waste brain cells over something you can do nothing about." --My Wife

Post Reply